View Issue Details

IDProjectCategoryView StatusLast Update
0000624Gameplay + OpenGL[All Projects] Bugpublic2017-04-25 14:42
ReporterBlue Shadow 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 Home x64
Summary0000624: Exit specials crash
DescriptionIf the value of a player start thing's first argument doesn't match the one passed to one of the exit specials (Exit_Normal or Exit_Secret), the engine crashes when attempting to load the next map.
Steps To ReproduceUsing the attached file, start on MAP01 and press the switch in front of you to exit. Skip the tally screen and proceed to the next map.
Additional InformationTested/produced with: 3.0pre-31-g1852079 and 2.4.0 (64-bit)

About the test file: the switch has Exit_Normal special assigned to it with the first argument set to some arbitrary value. Of course, the next map doesn't have a player start whose first argument matches that arbitrary value, hence the crash.
TagsNo tags attached.

Relationships

Activities

Blue Shadow

Blue Shadow

2017-04-25 07:44

reporter  

exit.wad (1,785 bytes)
CrashReport.zip (22,608 bytes)
_mental_

_mental_

2017-04-25 08:42

developer   ~0001546

This is the same problem I occasionally discovered here.
It's caused by AActor::UnlinkFromWorld() called twice for APlayerPawn object.
To fix the crash it's enough to assign NULL in this line instead of that magic value.
But I would like to ask Graf to take a look at this.
Graf Zahl

Graf Zahl

2017-04-25 11:39

administrator   ~0001547

The value is there to catch double unlinks, so the real fix should be to eliminate that duplicate.
Graf Zahl

Graf Zahl

2017-04-25 13:01

administrator   ~0001548

I delayed the abort until the travelling list is completely processed, this seems to bring back the intended error message.
_mental_

_mental_

2017-04-25 13:50

developer   ~0001549

It doesn't build, did you forget something to commit?
Graf Zahl

Graf Zahl

2017-04-25 14:42

administrator   ~0001550

Not forget, but the last change got lost somehow. Strange that is the second time in only a few days that this happened.

Issue History

Date Modified Username Field Change
2017-04-25 07:44 Blue Shadow New Issue
2017-04-25 07:44 Blue Shadow File Added: CrashReport.zip
2017-04-25 07:44 Blue Shadow File Added: exit.wad
2017-04-25 08:42 _mental_ Status new => confirmed
2017-04-25 08:42 _mental_ Note Added: 0001546
2017-04-25 11:39 Graf Zahl Note Added: 0001547
2017-04-25 13:01 Graf Zahl Status confirmed => resolved
2017-04-25 13:01 Graf Zahl Resolution open => fixed
2017-04-25 13:01 Graf Zahl Note Added: 0001548
2017-04-25 13:50 _mental_ Note Added: 0001549
2017-04-25 14:42 Graf Zahl Note Added: 0001550