View Issue Details

IDProjectCategoryView StatusLast Update
0000285GZDoom (All)[All Projects] Bugpublic2017-02-17 05:04
Reporterjewellds 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0000285: Menus are in the wrong aspect ratio.
DescriptionGZDoom stretches its graphics vertically by 20% to reproduce the non-square pixels of vanilla Doom. However, this scaling doesn't appear to happen in the menus, making the menu graphics appear squished.

This is irrespective of the screen's aspect ratio, as I tested this on both 4:3 and 16:9 resolutions.
Steps To ReproducePress ESC.
Additional InformationAttached are two screenshots - the first is of the most current devbuild (gzdoom-g2.4pre-530-g59db1a8) displaying the menu with incorrect aspect ratio. The second is of prboom-plus demonstrating a menu with more accurate scaling.
TagsGZDoom Menu

Relationships

Activities

Graf Zahl

Graf Zahl

2017-02-17 05:01

administrator   ~0000631

This is by design to allow clean pixel scaling. Stretching by a factor of 1.2 that doesn't look bad requires screen scaling factors that are a lot higher than the currently available 4 or 5.
jewellds

jewellds

2017-02-17 05:04

reporter  

prboomplus menu.PNG (227,656 bytes)
prboomplus menu.PNG (227,656 bytes)
gzdoom menu.PNG (355,992 bytes)

Issue History

Date Modified Username Field Change
2017-02-17 05:00 jewellds New Issue
2017-02-17 05:00 jewellds Tag Attached: GZDoom Menu
2017-02-17 05:01 Graf Zahl Status new => resolved
2017-02-17 05:01 Graf Zahl Resolution open => no change required
2017-02-17 05:01 Graf Zahl Note Added: 0000631
2017-02-17 05:04 jewellds File Added: gzdoom menu.PNG
2017-02-17 05:04 jewellds File Added: prboomplus menu.PNG