View Issue Details

IDProjectCategoryView StatusLast Update
0000249GZDoom (All)[All Projects] Bugpublic2017-02-14 15:03
ReporterEnjay 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0000249: GZDoom not good at detectng once you have left a swimmable 3D floor
DescriptionI accidentally made the attached setup in a real map (it wasn't quite what I intended) and noticed that there was some weirdness going on when I left the swimmable 3D floor. As long as I didn't break the surface of the 3D floor fully, GZDoom would continue to think that I was in a swimmable section even when I wasn't.

Noticed in the 12 Feb git build. 2.3.2 does not display this behaviour (i.e. it works as expected).
Steps To ReproduceTry the attached map. The only swimmable 3D floors are the ones in the pit and under the tunnel. The surrounding water is not set to be swimmable.

Jump into the 3D water then very carefully leave so that you don't jump up as you leave. If you manage this, then GZDoom will continue to think that you are in a swimmable sector even when you aren't. You can tell this by the slight drag that you can feel on the player movement and if you walk up to a wall, you can "climb" it and then remain floating as you move around the area. As long as you stay above the sector with the 3D water (which is non-swimmable BTW) then you can continue to float.

See this video for the technique to reproduce the bug.

https://youtu.be/pTCe7a131eQ

In the first and third attempts, I demonstrate the bug. In the second I jump up slightly as I leave the water and that's enough to cancel the swimming effect.
TagsNo tags attached.

Relationships

Activities

Enjay

Enjay

2017-02-12 07:30

reporter  

swimming.zip (3,249 bytes)
Graf Zahl

Graf Zahl

2017-02-12 19:00

administrator   ~0000539

I blame you for this, requesting that splash change. :P
Enjay

Enjay

2017-02-13 17:57

reporter   ~0000568

Heh, I had a funny feeling that might be related - and that I'd get the blame. ;)
Graf Zahl

Graf Zahl

2017-02-14 13:12

administrator   ~0000581

I hope it's better now. But if this also doesn't work right I'll revert this entirely.
Enjay

Enjay

2017-02-14 15:03

reporter   ~0000583

I just made a build and tested it in a few situations where I was experiencing the problem. It seems to be working as intended now. Thanks very much. :)

Issue History

Date Modified Username Field Change
2017-02-12 07:30 Enjay New Issue
2017-02-12 07:30 Enjay File Added: swimming.zip
2017-02-12 19:00 Graf Zahl Note Added: 0000539
2017-02-13 17:57 Enjay Note Added: 0000568
2017-02-14 13:12 Graf Zahl Status new => resolved
2017-02-14 13:12 Graf Zahl Resolution open => fixed
2017-02-14 13:12 Graf Zahl Note Added: 0000581
2017-02-14 15:03 Enjay Note Added: 0000583