View Issue Details

IDProjectCategoryView StatusLast Update
0000240Gameplay + OpenGL[All Projects] Featurepublic2017-02-13 17:59
ReporterNash 
Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionno change required 
Summary0000240: Export SingleActorFromTID to ZScript
DescriptionFor situations where you want to do things in ZScript based on things with TIDs.
TagsNo tags attached.

Relationships

Activities

ibm5155

ibm5155

2017-02-13 09:52

reporter   ~0000545

Isn't that related to this one? https://mantis.zdoom.org/view.php?id=145
Xaser

Xaser

2017-02-13 14:40

reporter   ~0000554

I'd even be hesitant to add something like this to the standard ZScript library (once that becomes a thing), since there isn't a good general-case answer to the question "which actor do I choose if there's more than one?" ActorIterator has a learning curve, but it's worth learning.
Graf Zahl

Graf Zahl

2017-02-13 15:39

administrator   ~0000560

No need. You can use an ActorIterator and just get the first return from it, that's exactly what this native function does. It's essentially:

let it = ActorIterator.Create(tid);
let ac = it.Next();
Nash

Nash

2017-02-13 17:59

reporter   ~0000569

Okay got it, thanks!

Issue History

Date Modified Username Field Change
2017-02-11 09:30 Nash New Issue
2017-02-13 09:52 ibm5155 Note Added: 0000545
2017-02-13 14:40 Xaser Note Added: 0000554
2017-02-13 15:39 Graf Zahl Note Added: 0000560
2017-02-13 15:40 Graf Zahl Status new => resolved
2017-02-13 15:40 Graf Zahl Resolution open => no change required
2017-02-13 17:59 Nash Note Added: 0000569