View Issue Details

IDProjectCategoryView StatusLast Update
0000283GZDoom (All)[All Projects] Featurepublic2017-02-17 07:51
ReporterMajor Cooke 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Summary0000283: GetMousePosition for Menus
DescriptionReturns the vector2 of the mouse's placement on the screen.
TagsNo tags attached.

Relationships

Activities

Graf Zahl

Graf Zahl

2017-02-17 04:58

administrator   ~0000630

Every mouse event got its coordinates attached. Of course, if the user sets the mouse to touchscreen-like, you won't receive any mouse move events while the button is not pressed and that's entirely by design.

Before I even consider this, please show your use case.
Major Cooke

Major Cooke

2017-02-17 06:50

reporter   ~0000633

Last edited: 2017-02-17 06:53

View 2 revisions

https://youtu.be/gPtpE8lgUIQ?t=220

A menu like this where you can move the mouse to, for example, one edge of the screen and have it 'mouse' over so the menu can scroll up, down, left or right through menus.

I.e. if you move the mouse close enough to the top, bottom, left or right, one can essentially use this for scrolling.

Also some menus have effects where if the mouse comes closer to certain buttons, the buttons will grow larger/smaller based on position.

Graf Zahl

Graf Zahl

2017-02-17 07:50

administrator   ~0000637

You get all relevant info through the MouseEvent function. But since you can set the menu to touchscreen-like I definitely won't add features that only work with hovering. These will break at the latest when the mod gets eventually played on a touchscreen device.

Issue History

Date Modified Username Field Change
2017-02-16 22:06 Major Cooke New Issue
2017-02-17 04:58 Graf Zahl Note Added: 0000630
2017-02-17 06:50 Major Cooke Note Added: 0000633
2017-02-17 06:53 Major Cooke Note Edited: 0000633 View Revisions
2017-02-17 07:50 Graf Zahl Note Added: 0000637
2017-02-17 07:51 Graf Zahl Status new => resolved
2017-02-17 07:51 Graf Zahl Resolution open => won't fix