View Issue Details

IDProjectCategoryView StatusLast Update
0000250GZDoom (All)[All Projects] Bugpublic2017-02-13 15:17
Reporterrex 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version7 Pro
Summary0000250: Selectively Setting Up Fog in Maps?
DescriptionI have a map that has fog (via an OPEN Script using Sector_SetFade) in some areas only. [FYI, these are meant to represent large, walk-in freezers.] This effect worked perfectly until recently. I believe the introduction of a defaultmap definition in MAPINFO may be causing the freezer fog to be over-ridden. In other words, I can get a default fog value for all maps, or I can get it selectively in various sectors in each map. But I can't get both.
Steps To Reproduce1. Open map
2. Walk to freezer area & see no fog
3. Repeat
Additional InformationFrom Graf in this thread:
The problem is simply that the fog density being set in MAPINFO is map global and will affect all fogged sectors. If you do not want that you have to resort to a post 2.3 feature which allows setting this per sector via UDMF or ACS.
And:
If you just need an automated way to convert light levels into sector colors, I guess the only way to do that is to define a ZSCRIPT actor that scans the entire sector array in its Tick function and converts the light level into sector color.

Is the ZSCRIPT route the only solution, or will this be addressed in any upcoming GZDooM official release?
TagsNo tags attached.

Relationships

Activities

Graf Zahl

Graf Zahl

2017-02-13 13:12

administrator   ~0000547

Checking the implementation, the global setting for fog has no effect on black fog (i.e. light diminishing.) I think the only option you really need is to disable light diminishing per map, right?
Rachael

Rachael

2017-02-13 14:54

administrator   ~0000556

Turning off light diminishing while keeping fog for the freezer sections would be ideal.
Graf Zahl

Graf Zahl

2017-02-13 15:17

administrator   ~0000558

Done.

Issue History

Date Modified Username Field Change
2017-02-12 07:51 rex New Issue
2017-02-13 13:12 Graf Zahl Status new => feedback
2017-02-13 13:12 Graf Zahl Note Added: 0000547
2017-02-13 14:54 Rachael Note Added: 0000556
2017-02-13 15:17 Graf Zahl Note Added: 0000558
2017-02-13 15:17 Graf Zahl Status feedback => resolved
2017-02-13 15:17 Graf Zahl Resolution open => fixed