View Issue Details

IDProjectCategoryView StatusLast Update
0000246GZDoom (All)[All Projects] Bugpublic2017-02-14 16:27
ReporterCherepoc 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0000246: Name properties throw "Numeric type expected" error
Descriptiong2.4pre-392-gd2affc7
When you use a name variable for property, assigning a value to it in the default block throws "Numeric type expected" error. String variables work fine.
Example:

class MyClass : Actor
{
    Name SomeName;
    property SomeName : SomeName;
    
    Default
    {
        MyClass.SomeName 'yay';
    }
}
TagsNo tags attached.

Relationships

Activities

Graf Zahl

Graf Zahl

2017-02-12 18:56

administrator   ~0000536

Yeah, not implemented yet. Since Name is an int internally it gets caught in the wrong check.

Issue History

Date Modified Username Field Change
2017-02-11 15:14 Cherepoc New Issue
2017-02-12 18:56 Graf Zahl Note Added: 0000536
2017-02-14 16:27 Graf Zahl Status new => resolved
2017-02-14 16:27 Graf Zahl Resolution open => fixed