View Issue Details

IDProjectCategoryView StatusLast Update
0000385Gameplay + OpenGL[All Projects] Bugpublic2017-03-06 12:06
ReporterTormentor667 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Summary0000385: Inconsistency between GZDB and GZDoom on texture offset (negative scaling)
DescriptionI don't know if this is a GZDB bug or a GZDoom bug so I am cross-posting this here and in the GZDB thread. Can't tell since when it happens but some texture alining doesn't work properly ingame if it works well in GZDB.

GZDB (laterst build r2930)
http://i.imgur.com/8aei31v.jpg

GZDoom (latest build from today)
http://i.imgur.com/oo0Hrk5.jpg

GZDB texture setting:
http://i.imgur.com/IH5mnD5.jpg

I think that the negative scaling somehow makes problems in terms of consistency how the engine handles it and how the editor handles it.
TagsNo tags attached.

Relationships

Activities

Tormentor667

Tormentor667

2017-03-05 16:06

reporter  

texture.jpg (78,667 bytes)
texture.jpg (78,667 bytes)
ingame.jpg (51,951 bytes)
ingame.jpg (51,951 bytes)
ineditor.jpg (76,781 bytes)
ineditor.jpg (76,781 bytes)
Graf Zahl

Graf Zahl

2017-03-05 18:30

administrator   ~0000873

It was changed recently because scrolling textures with a negative scale were scrolling in the wrong direction. This was a GZDoom-exclusive issue, in ZDoom it was correct, it was also introduced somewhere in 2012 when some mirroring issues were badly fixed.


Apparently GZDB followed the incorrect setting in older GZDooms.
Graf Zahl

Graf Zahl

2017-03-05 18:32

administrator   ~0000874

I also strongly recommend to use the 'worldpanning' setting with mirrored textures to avoid anomalies.
ZZYZX

ZZYZX

2017-03-05 21:33

reporter   ~0000880

What exactly was changed? What was the old behavior and what's the new one? I'll change it in GZDB.
Tormentor667

Tormentor667

2017-03-06 11:26

reporter   ~0000894

"Worldpanning"?
Graf Zahl

Graf Zahl

2017-03-06 12:06

administrator   ~0000895

@ZZYZX:
For flipped textures the offset coordinates were also flipped by being multiplied with the negative scale.

@Tormentor:

Worldpanning is a texture option that uses world coordinates for texture offsets, not texel coordinates. The entire texel coordinate thing was a misguided idea by Randi that over time has caused endless trouble and sadly I failed to address this when TEXTURES got made by changing the default.

Issue History

Date Modified Username Field Change
2017-03-05 16:06 Tormentor667 New Issue
2017-03-05 16:06 Tormentor667 File Added: ineditor.jpg
2017-03-05 16:06 Tormentor667 File Added: ingame.jpg
2017-03-05 16:06 Tormentor667 File Added: texture.jpg
2017-03-05 18:30 Graf Zahl Note Added: 0000873
2017-03-05 18:32 Graf Zahl Status new => resolved
2017-03-05 18:32 Graf Zahl Resolution open => no change required
2017-03-05 18:32 Graf Zahl Note Added: 0000874
2017-03-05 21:33 ZZYZX Note Added: 0000880
2017-03-06 11:26 Tormentor667 Note Added: 0000894
2017-03-06 12:06 Graf Zahl Note Added: 0000895