View Issue Details

IDProjectCategoryView StatusLast Update
0000280GZDoom (All)[All Projects] Featurepublic2017-02-17 14:26
ReporterCamaxide 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status on holdResolutionreopened 
PlatformPCOSWindowsOS Version10
Summary0000280: Possibility to link intermission scripts
Descriptionby using 'enterpic' in mapinfo you can either chose to display a fullscreen image of your next level, or you can create a world map showing which maps you have finished and which you are about to enter.
But there seem to be no option to link multiple of these together. Say the player finish Map01, he gets the kills-count etc. and press use - now the player would enter the world-map and see the map he just finished - and the map he is going to, as the player press use I would like him to move on to a second "enterpic" - or preferably just a continue of it - just link you can use 'link =' in the endgame intermissions to go to the next intermission - if no link = would be present, the press of use would continue to the next level (or to the cluster entertext if any is set'.
I've researched quite a bit, and it seem this kind of action is impossible today, but would be very useful for making more interesting and customisable things between levels. I have tried to "fake" it by creating extra levels that is scripted to end - but if those have intermission enabled they will show a kill-count, and if intermission is disabled they basicly dont do anything for extra intermission options.. so I'd love to see the function added to use something like "link = " inside enterpic lumps to allow to chain more together between levels.

Please tell if I didn't make it clear what I mean, English isn't my primary language :)
TagsNo tags attached.

Relationships

Activities

Graf Zahl

Graf Zahl

2017-02-16 13:59

administrator   ~0000622

You can set a separate image with 'exitpic =' for the 'finished' screen.
Camaxide

Camaxide

2017-02-16 14:14

reporter   ~0000623

Last edited: 2017-02-16 14:20

View 2 revisions

I already define exitpic for each map - exitpic defines what image to show behind the kill-count screen, and cant be used for what I requested.

I'll try to explain it better.

I'd like to be able to put together more links to the "chain" between two levels - say
1: Kill-count screen (exitpic) (player press use)
2: World map showing where you've been and where to go (enterpic) (player press use)
3: A Large image for the next map in line is displayed with the name of the map on top (enterpic) (player press use)
4: Story text for the next map is displayed (cluster entertext) (player press use)
5: Map start

Currently 2 and 3 both use the same lump, and can't be combined. One can't extend the use within the lump to do more actions - and one can not define enterpic lump to jump to a second enterpic lump.

I'd like to be able to do so (jump from enterpic lump to next with something like Link = ... just as you can when defining intermission's for the end-game.

Graf Zahl

Graf Zahl

2017-02-16 16:22

administrator   ~0000626

So you want an entirely new screen added into the sequence? I don't think I'll do that before exporting that entire module to scripting, but that may take a while.
Camaxide

Camaxide

2017-02-17 09:28

reporter   ~0000640

I don't know so much about the technicality behind it, but what I want is to be able to define two enterpics to come one after the other - so no "new" lump-type or so, but the ability to tell at the end of a enterpic-lump that it should jump to another enterpic-lump (in theory this would allow to go between many enterpic-lumps with different content before moving on to the next map.)
From the above list I originaly have 1-3-4-5 - while after starting to produce the world-map I now have 1-2-4-5 since 2 and 3 needs the same lump and can't be combined inside the same lump. (they are both enterpic).

The scripting what does it mean? it's the new zscript setup? Can it be combined with the old decorate/mapinfo etc.? or would it require a full rewrite of all lumps for me to implement it?
Any finger in the air guess on how long a while is? 3 months - a year? :)

Just good to know how I should plan progress - I'm hoping to be done by summer with the second episode for a release - but I hoped that last February also - so who knows :)
Graf Zahl

Graf Zahl

2017-02-17 12:37

administrator   ~0000642

It means that the code as written cannot do what you want, it would reqiure some major redesign.
And I'm not going to do this unless the code for these screens has been completely ported to ZScript.
Camaxide

Camaxide

2017-02-17 14:26

reporter   ~0000644

Yes that makes sense to not do the same job twice when things are anyway going zscript. What I ment to ask is when the new zscript is up, and if this is then implemented - will it be compatible with the old stuff? Like can I use some lumps that use zscript, while all the old lumps I use is not zscript? :) (meaning I would not have to rewrite decorate etc. for zscript.

Issue History

Date Modified Username Field Change
2017-02-16 12:15 Camaxide New Issue
2017-02-16 13:25 Rachael Project zdoom.org (Site) => GZDoom (All)
2017-02-16 13:59 Graf Zahl Status new => resolved
2017-02-16 13:59 Graf Zahl Resolution open => no change required
2017-02-16 13:59 Graf Zahl Note Added: 0000622
2017-02-16 14:14 Camaxide Note Added: 0000623
2017-02-16 14:20 Camaxide Note Edited: 0000623 View Revisions
2017-02-16 15:08 Camaxide Status resolved => feedback
2017-02-16 15:08 Camaxide Resolution no change required => reopened
2017-02-16 16:22 Graf Zahl Note Added: 0000626
2017-02-16 16:22 Graf Zahl Status feedback => on hold
2017-02-17 09:28 Camaxide Note Added: 0000640
2017-02-17 12:37 Graf Zahl Note Added: 0000642
2017-02-17 14:26 Camaxide Note Added: 0000644