View Issue Details

IDProjectCategoryView StatusLast Update
0000276GZDoom (All)[All Projects] Featurepublic2017-02-16 16:31
ReporterRockstarRaccoon 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Summary0000276: Action Special for Animated Doors which open without closing and can be closed manually.
DescriptionI'm using animated doors heavily, and would like a way to open or close them without the open-close stuff at will. This would be an action special, the same as 14: Door_Animated, but without the Delay, just Door_Animated_Open and Door_Animated_Close.

I want this because the animated doors are the most effective way to replicate Metroid Prime's hatch-doors, but having ones that stay open (like a blast cover which disappears permenantly when you blow it up) or suddenly shut behind you requires be to manually code in the animation...
Steps To ReproduceTLDR: I'm asking you to make a pair of Action Specials which split the existing one apart.
TagsAction Specials, Animated Doors, Effects

Relationships

Activities

RockstarRaccoon

RockstarRaccoon

2017-02-16 00:52

reporter   ~0000614

Last edited: 2017-02-16 01:51

View 4 revisions

I think the permenant opening can be done just by going into p_doors.cpp , in the function DAnimatedDoor::Tick, and changing the code for the Waiting case to the following...
		if (m_delay != -1 && !m_Timer--)
        {
            if (!StartClosing())
            {
                m_Timer = m_Delay;
            }
        }

This would mean that an open-time of -1 would be permenant opening.

The closing would be more complicated, because I don't think just binding an action special to StartClosing() would do it. Either way, I'd like the ability to permenantly open an animated door. :3

RockstarRaccoon

RockstarRaccoon

2017-02-16 01:55

reporter   ~0000615

You could also add a separate case called "Open", which is turned to when the door is done opening with a delay of -1 or a Door_Animated_Open Action Special.
Graf Zahl

Graf Zahl

2017-02-16 05:18

administrator   ~0000617

Open shouldn't be a problem. Close I'm not so sure about, I'll have to check if the setup allows detecting that.
Graf Zahl

Graf Zahl

2017-02-16 10:47

administrator   ~0000619

Do you need this for UDMF or Hexen map format. Keep in mind that the amount of free specials for Hexen format is already very limited, we'd like to reserve these for really important things.
Graf Zahl

Graf Zahl

2017-02-16 11:29

administrator   ~0000621

Opening without closing can already be done by setting the delay to 0.
I added a new 'close' special for this type of door.
RockstarRaccoon

RockstarRaccoon

2017-02-16 16:29

reporter   ~0000627

I'm using UDMF: I'm a firm believer that everyone should use UDMF, because the drawbacks are so minor for a format which universalizes everything in such an elegant and easy to understand way.
RockstarRaccoon

RockstarRaccoon

2017-02-16 16:30

reporter   ~0000628

Last edited: 2017-02-16 16:31

View 3 revisions

That's awesome! Thanks so much! I look forward to using that in the next development release! :D

Edit: or, like, you know, whenever I get there. XD
But seriously, this is a good thing to add: animated doors have much more potential than we've given them the ability to achieve.

Issue History

Date Modified Username Field Change
2017-02-15 22:32 RockstarRaccoon New Issue
2017-02-15 22:49 RockstarRaccoon Tag Attached: Effects
2017-02-15 22:49 RockstarRaccoon Tag Attached: Action Specials
2017-02-15 22:49 RockstarRaccoon Tag Attached: Animated Doors
2017-02-16 00:52 RockstarRaccoon Note Added: 0000614
2017-02-16 01:39 RockstarRaccoon Note Edited: 0000614 View Revisions
2017-02-16 01:50 RockstarRaccoon Note Edited: 0000614 View Revisions
2017-02-16 01:51 RockstarRaccoon Note Edited: 0000614 View Revisions
2017-02-16 01:55 RockstarRaccoon Note Added: 0000615
2017-02-16 05:18 Graf Zahl Note Added: 0000617
2017-02-16 10:47 Graf Zahl Note Added: 0000619
2017-02-16 11:29 Graf Zahl Status new => resolved
2017-02-16 11:29 Graf Zahl Resolution open => fixed
2017-02-16 11:29 Graf Zahl Note Added: 0000621
2017-02-16 16:29 RockstarRaccoon Note Added: 0000627
2017-02-16 16:30 RockstarRaccoon Note Added: 0000628
2017-02-16 16:31 RockstarRaccoon Note Edited: 0000628 View Revisions
2017-02-16 16:31 RockstarRaccoon Note Edited: 0000628 View Revisions