View Issue Details

IDProjectCategoryView StatusLast Update
0000256GZDoom (All)[All Projects] Bugpublic2017-02-14 12:07
ReporterMajor Cooke 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Summary0000256: NumberFields broken
DescriptionTry loading D4D. It will fail to load saying:

Script error, "D4D.pk3:menudef.txt" line 264:
Unknown CVar 0
TagsNo tags attached.

Relationships

Activities

Major Cooke

Major Cooke

2017-02-13 06:34

reporter   ~0000544

Last edited: 2017-02-13 06:34

View 2 revisions

	OptionMenuItemNumberField Init (String label, Name command, float minimum = 0, float maximum 
= 100, float step = 1, CVar graycheck = null)
    {
        Super.Init(label, command, graycheck);
        mMinimum = min(minimum, maximum);
        mMaximum = max(minimum, maximum);
        mStep = max(1, step);
        return self;
    }


Turns out this doesn't actually look for the cvar itself. This makes it impossible to use NumberFields entirely.

Graf Zahl

Graf Zahl

2017-02-13 15:54

administrator   ~0000562

You have an extraneous 0 there which triggers a newly added error check that was previously accepted silently.
Seems I have to demote it to a warning so that all those modders can conveniently ignore it. :(
Major Cooke

Major Cooke

2017-02-13 16:05

reporter   ~0000565

Last edited: 2017-02-13 16:06

View 2 revisions

That extraneous 0 is for the increment count which aught to mean "use default", correct?

Graf Zahl

Graf Zahl

2017-02-13 17:15

administrator   ~0000566

No, that fourth number is extraneous. The third one is the increment counter.

Issue History

Date Modified Username Field Change
2017-02-12 21:57 Major Cooke New Issue
2017-02-13 06:34 Major Cooke Note Added: 0000544
2017-02-13 06:34 Major Cooke Note Edited: 0000544 View Revisions
2017-02-13 15:54 Graf Zahl Note Added: 0000562
2017-02-13 16:05 Major Cooke Note Added: 0000565
2017-02-13 16:06 Major Cooke Note Edited: 0000565 View Revisions
2017-02-13 17:15 Graf Zahl Note Added: 0000566
2017-02-14 12:07 Graf Zahl Status new => resolved
2017-02-14 12:07 Graf Zahl Resolution open => fixed